Login    Register
User Information
Username:
Password:
We are a free and open
community, all are welcome.
Click here to Register
Sponsored
Who is online

In total there are 62 users online :: 3 registered, 0 hidden and 59 guests


Most users ever online was 155 on Mon Aug 15, 2016 1:40 am

Registered users: Bing [Bot], Google [Bot], Yahoo [Bot] based on users active over the past 5 minutes

The Team
Administrators
Global Moderators
global_moderators.png CS

need help fixing a KWA M4

This area is for the discussion of BB or airsoft sub machine guns, and or other small arms such as pellets.
Sponsored 
  • Author
    Message

need help fixing a KWA M4

Unread postAuthor: grock » Wed Sep 02, 2009 10:30 pm

hey guys, for no reason, my KWA M4 stopped firing, and when i remove the pins, i can't "break" it open like normal. i googled this problem, and everything i could find said the piston needed to be reset by firing it a few times. my problem however, is that i cannot break the gun open OR fire it. So. does anyone know how to reset the piston on an airsoft M4 besides firing it or taking it apart?

Thanks
  • 0

User avatar
grock
2nd Lieutenant
2nd Lieutenant
 
Posts: 231
Joined: Mon Dec 29, 2008 2:59 pm
Reputation: 0

Unread postAuthor: jonnyboy » Wed Sep 02, 2009 10:43 pm

Maybe this will help. Seems the pin above the trigger is a little sticky. Have you tried the guide on mechbox.com?

EDIT
This guy had the same problem he got it open but he ended up destroying his piston. At least pistons aren't terribly expensive.
  • 0

mobile chernobyl wrote:I can shoot a Canuter Valve off my '82 Chevy Ram F150 AT LEAST 3/4 Mile with 'ma cannon made of soup cans duct taped together, then I just squirt some bacardi 151 in the chamber and hold up my cigarrete lighta and WHOOSH! That thing flies at least 3/4 mile
User avatar
jonnyboy
Colonel
Colonel
 
Posts: 591
Joined: Mon May 26, 2008 1:20 pm
Location: Williamston MI USA
Reputation: 0

Unread postAuthor: grock » Wed Sep 02, 2009 11:13 pm

thanks for the quick reply, the pin comes out just fine, but then i can only pull the back of the upper reciver up about half an inch.
  • 0

User avatar
grock
2nd Lieutenant
2nd Lieutenant
 
Posts: 231
Joined: Mon Dec 29, 2008 2:59 pm
Reputation: 0

Unread postAuthor: Cannibal Corpse » Wed Sep 02, 2009 11:59 pm

If I get what your saying, you took out the rear reciver pin and your pulling up to make it split? If so most metal bodied guns use one peice hopup's so to do that you half to remove the front reciver pin too, then slide the upper reciver forward.

EDIT: The reason it may have stopped fireing is you could have blown the fuse or the motor conntacts could have fallen off. When you pull the trigger does it make a clicking sound? Also to reset your piston fire the gun a few times on semi or open it up and reset it.
  • 0

User avatar
Cannibal Corpse
Specialist
Specialist
 
Posts: 44
Joined: Sun Nov 04, 2007 5:01 pm
Reputation: 0

Unread postAuthor: grock » Thu Sep 03, 2009 12:40 am

removing the front pin does not change the situation, other then i can get the front half up about 1/4" , but i cannot slide the upper foreward. my fuse is good, and as near as i can tell from removing the plate that covers it, my contacts are good too. i cant hear a clicking sound when i pull the trigger, and i cant fire it at all, so i cant reset the piston that way
  • 0

User avatar
grock
2nd Lieutenant
2nd Lieutenant
 
Posts: 231
Joined: Mon Dec 29, 2008 2:59 pm
Reputation: 0

Unread postAuthor: TX » Mon Sep 07, 2009 10:38 pm

STOP PULLING UP!!!!

Your piston is locked in the rear position. This will not allow you to pull the upper receiver off because the piston is in the way. You most likely have damaged your piston if you have forcefully tried to split the receivers.

Charge your battery and then fire in semi to reset the piston forward. PM me if oyu need more help.
  • 0


TX
Private
Private
 
Posts: 5
Joined: Mon Dec 19, 2005 12:50 pm
Reputation: 0

Unread postAuthor: zim0909 » Tue Sep 08, 2009 3:37 am

One of my friends who is a tech taught me how to reset pistons without opening the gearbox. First you remove the pistol grip of your gun. This is done by removing the 2 screws from the base plate, unplugging the wires on your motor, removing the motor, and finally unscrewing the the two screws that connect to your gearbox. Then take a metal clothes hanger and cut of a piece about 5 inches long. Then, make a small hook on the piece, small enough to fit in the hole under the gearbox but as large as possible. Put that hook up into your gearbox and observe the piece next to the gear that your motor connects to. This is called an anti reversal latch and that is what holds the pinion gear which in turn holds every other gear. Use the hook that you made to grab onto the anti-reversal latch and pull until it releases. After that reassemble the pistol grip and tighten all the screws. If the problem persist, you can either check the shimming of the gears and the timing or if your not confident in working on gearboxes, you can take it to your local airsoft technician.
  • 0


zim0909
Private
Private
 
Posts: 1
Joined: Tue Sep 08, 2009 3:28 am
Reputation: 0

Sponsored

Sponsor
 


Unread postAuthor: TX » Tue Sep 08, 2009 2:44 pm

The pinion gear actually holds the bevel gear in place. I am an airsoft tech :D

The clicking sound made by your gun simply means the motor cannot turn over. On a KWA this can only be caused by a few problems, (1) not enough power to turn over the motor, (2) something internally is binding, (3) motor height is off

KWA's do not and should not ever be shimmed with all stock parts. Try charging the battery first and then fire in semi a few times. If that does not work, try backing your motor height out and try my first suggestion again. If neither of those work, I suggest taking your gun to a local airsoft store to get worked on as it most likely is an internal problem.
  • 0


TX
Private
Private
 
Posts: 5
Joined: Mon Dec 19, 2005 12:50 pm
Reputation: 0

Unread postAuthor: grock » Tue Sep 08, 2009 8:05 pm

i charged up my battery, and backed the motor out almost all the way. now when i pull the trigger, a louder clicking sound is made and it seems like the motor is jumping inside the grip. does that mean there is something internally binding it?
  • 0

User avatar
grock
2nd Lieutenant
2nd Lieutenant
 
Posts: 231
Joined: Mon Dec 29, 2008 2:59 pm
Reputation: 0

Unread postAuthor: TX » Thu Sep 10, 2009 2:39 am

Is it just a clicking sound or more of a whine?

If it is just clicking then it sounds like a binding issue. You should think about taking it to a local airsoft tech. I could tell you more if I saw your gun in person but I advise taking it to a tech. Also, what did you do to back out the motor?
  • 0


TX
Private
Private
 
Posts: 5
Joined: Mon Dec 19, 2005 12:50 pm
Reputation: 0

Unread postAuthor: grock » Fri Sep 11, 2009 12:12 am

i backed out the set screw in the bottom of the grip, and it just clicks, doesnt whine
  • 0

User avatar
grock
2nd Lieutenant
2nd Lieutenant
 
Posts: 231
Joined: Mon Dec 29, 2008 2:59 pm
Reputation: 0

Return to BB/Airsoft/Pellet Gun Discussion

Who is online

Registered users: Bing [Bot], Google [Bot], Yahoo [Bot]

Reputation System ©'